月別アーカイブ: 2011年5月

1812J 再設定2

メモリ買ってきたので続き

メモリ増設
天板の黒ネジ1本外して、両サイドのドライバーマーク付近にマイナスドライバーで引っかかた部分を押したら、
簡単に空いたので、SO-DIMM_DDR2700(256MB)を取り付けた。(中古だから200円だったw)
router#show version   #メモリ増えたか確認
Cisco 1812-J (MPC8500) processor (revision 0x400) with 354304K/38912K bytes of memory.

現在のインターネット接続環境は、光プレミアム+OCNでPPPOEで接続

router#show runnning-config
version 15.1 service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
boot-start-marker
boot-end-marker
!
clock timezone JST 9 0 #日本時刻へ変更
crypto pki token default removal timeout 0
!
ip dhcp pool local #localという名のdhcp poolの設定
network 192.168.1.0 255.255.255.0
default-router 192.168.1.1
dns-server xxx.xxx.xxx.xxx
!
multilink bundle-name authenticated
!
!
interface FastEthernet0
no ip address
duplex auto
speed auto
pppoe enable group global
pppoe-client dial-pool-number 1
interface FastEthernet2
interface FastEthernet4
interface FastEthernet6
interface FastEthernet8
interface Vlan1
ip address 192.168.1.1 255.255.255.0
ip nat inside
ip virtual-reassembly in
ip tcp adjust-mss 1398
ip forward-protocol nd
no ip http server
no ip http secure-server
!
logging esm config
access-list 101 permit ip 192.168.1.0 0.0.0.255 any
dialer-list 1 protocol ip permit
no cdp run
!
!
!
end

とりあえずつながったけど、よくわかってない設定もあるのでおいおい調べたり、セキュリティを上げたりしよう。

あと、TELNETはダメでSSHで接続出来るようにもしよう。

1812J 再設定

1812Jを手に入れてから放置してたので今日から設定。

手に入れた当時ちょっと触ったけどあまり覚えてないからまず初期化。
USB-シリアル変換でパソコンと1812Jをつなぎ、teratermでシリアルポートに接続する。
1812Jを起動し、起動中にALT+Bを押してrommonにする。

rommon 2 > confreg 0x2141 #コンフィグレーションレジスタ変更
rommon 3 > reset

再起動
Would you like to enter the initial configuration dialog? no #セットアップモードに入りますか?
Router>enable
Router#erase startup-config  #パスワード等セッテファイル削除
Erasing the nvram filesystem will remove all configuration files! Continue? [confirm]y[OK]
Erase of nvram: complete
Router#
*May 15 10:54:34.903: %SYS-7-NV_BLOCK_INIT: Initialized the geometry of nvram
Router#configure terminal
Router(config)#config-register 0x2102
Router(config)#end
Router#reload
System configuration has been modified. Save? [yes/no]: no
Proceed with reload? [confirm]y

再起動
Would you like to enter the initial configuration dialog? no
router>show version
Configuration register is 0x2102 #コンフィグレジスタ値を確認

続きを読む

Murmur Registration server crash

debian 6.0_x64にmumbleのページからStatic Linux Serverのmurmur1.2.3を
使ってサーバを立ち上げようとしたけどmurmur.iniでregistrationしようとするとサーバが落ちる現象が発生。
※以下のように#を外すと落ちる。
registerPassword=secret
registerUrl=http://mumble.sourceforge.net/
registerHostname=YOUR HOSTNAME or IP

 

通常のログには表示されないので、オプションをつけて実行して様子を見ると以下のエラーが出た瞬間落ちてる。
$./murmur.x86 –fg –v –ini murmur.ini
※-fg(フォアグランドで実行) –v(詳細ログを表示)
murmur.x86: relocation error: /usr/lib32/libresolv.so: symbol strlen, version GLIBC_2.0 not defined in file libc.so.6 with link time reference

 

下のblogにソースからコンパイルし直すか、apt-get install mumble-serverするように書いてある。
blog参考:http://kcode.de/wordpress/1754-mumble-server-murmur-on-debian-6-0-squeeze-x64-64-bit-amd64

コンパイルしてみる。
コンパイル参考:http://mumble.sourceforge.net/BuildingLinux

http://sourceforge.net/projects/mumble/files/Mumble/1.2.3/
ここからmumble-1.2.3.tar.gzをダウンロード
#tar zxvf mumble-1.2.3.tar.gz
#cd mumble-1.2.3
#qmake -recursive main.pro CONFIG+=no-client
#make
#ls –l ./release/murmurd ←出来た実行ファイル
-rw-r–r– 1 root root 2740508 May 14 00:01 ./release/murmurd
※最初はいくつか不足してみたいでsqliteやlibqt4-sql-sqlite等入れたらうまく動いた気がする・・・

 

起動して以下のログがあったのでRegistration成功かな!?
Registration: New registration successfull

後は接続の所のインターネットに表示されたのを確認出来たから、おわり。
※載るまで1時間くらいかかった。