L2TP/IPSEC-VPN IX2025 リモートアクセス.

リモートアクセスVPNテスト

シナリオ

想定1:インターネットVPNを使用したリモートアクセスVPN
想定2:VPN構築後にiphoneからインターネットに接続する

機器:NEC IX2025(8.11.11) とiphone

目標1:LTE通信のiphoneからIX2025までをVPNでつなぎ、internal内のPCにリモートデスクトップで接続する
目標2:iphoneからインターネットに接続する

簡易ネットワーク

ix2025_l2tp-ipsec-vpn

IX2025 L2TP/IPSEC-VPN設定

config

hostname ix2025
!
ip ufs-cache enable
ip route default FastEthernet0/0.1
ip access-list all-block deny ip src any dest any
ip access-list all-pass permit ip src any dest any
ip access-list sec-list permit ip src any dest any
ip access-list vpn permit udp src any sport any dest any dport eq 500
ip access-list vpn permit udp src any sport any dest any dport eq 4500
ip access-list dynamic dyn-access access all-pass
!
ike nat-traversal
ike proposal ike1 encryption aes-256 hash sha group 1024-bit
ike proposal ike2 encryption aes hash sha group 1024-bit
ike proposal ike3 encryption 3des hash sha group 1024-bit
ike policy ike-policy peer any key XXXXXXX ike1,ike2,ike3
!
ipsec autokey-proposal sec1 esp-aes-256 esp-sha
ipsec autokey-proposal sec2 esp-aes esp-sha
ipsec autokey-proposal sec3 esp-3des esp-sha
ipsec dynamic-map ipsec-map sec-list sec1,sec2,sec3
!
proxy-dns ip enable
!
ppp profile プロバイダー
 authentication myname XXXXX@XXXXXX
 authentication password XXXXX@XXXXX パスワード
!
ppp profile L2TP-IPSEC-VPN
 authentication request chap
 authentication password ユーザー名 パスワード
 lcp pfc
 lcp acfc
 ipcp ip-compression
 ipcp provide-remote-dns 192.168.1.254
 ipcp provide-ip-address range 192.168.1.101 192.168.1.102
!
interface FastEthernet1/0.0
 ip address 192.168.1.254/24
 ip proxy-arp 
 ip dhcp binding 192.168.1.0/24
 no shutdown
!
interface FastEthernet0/0.1
 encapsulation pppoe
 auto-connect
 ppp binding プロバイダー
 ip address ipcp
 ip mtu 1454
 ip tcp adjust-mss auto
 ip napt enable
 ip napt static FastEthernet0/0.1 udp 500
 ip napt static FastEthernet0/0.1 udp 4500
 ip napt static FastEthernet0/0.1 50
 ip filter vpn 100 in
 ip filter all-block 65535 in
 ip filter dyn-access 100 out
 ip filter all-block 65535 out
 no shutdown
!
interface Tunnel0.0
 ppp binding L2TP-IPSEC-VPN
 tunnel mode l2tp ipsec
 ip unnumbered FastEthernet1/0.0
 ip tcp adjust-mss auto
 ipsec policy transport ipsec-map
 no shutdown

iphone L2TP/IPSEC-VPN設定準備

iphone -> 設定 -> VPN -> VPN構成を追加

タイプ:L2TP
説明:IX2025
サーバ:XXX.XXX.XXX.XXX (固定IPアドレス)
アカウント:userX
RSA SecureID:無効
パスワード:XXXXXXXXXX
シークレット:XXXXXX //事前共有鍵を指定
すべての信号を送信:有効

iphone PCへリモートデスクトップ

app storeからmicrosoft RD Clientをインストール

RD Clientの設定して接続

PC名:192.168.1.XXX (PCのIPアドレス)
ユーザーアカウント:<PCのユーザー名>
パスワード:<PCのパスワード>

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です